Jump to content

Welcome to the Heroes of Newerth forums

The forums have received a complete makeover. Click the button below to read more about it.
Read more

Recommended Posts

Just got a new laptop with specs: i5 9300h and Nvidia RTX 2060 and dual channel 16gb ram. Im also on 500/500 mbit fiber network. It doess not matter how i set the graphics inside HoN, im lagging so much either way. Im almost around 100fps... I contacted support, they tell me to go to this forum, so here i am. 

The lag is not too bad when playing practice or against bots, but when playing midwars, its unplayable. 

No clues on where to begin looking. 

ive noticed 2 messages in the console (CTRL+F8) in game:
"Assembled snapshot for frame: XXXXX from 2 pieces"
and also
"Rewinding effect /world/props/XXXXX/XXXX/XXXX.effect to XXXXX milliseconds"

Thanks in advance to any ideas on this matter!

Link to post
Share on other sites

What I've done:

updated Windows

Updated drivers 

Re-installed game 

Tested v-sync

Tested open gl

Tested running in 48fps instead of 120

Run HoN repair as admin

Run HoN repair as admin and also connected to my phone's 4g Network instead, if there was some prob with my IP.

Tried playing from phones network

 

 

Edited by oliiver
Link to post
Share on other sites

Tried switching the graphics card to the built in intel chip, turned settings down to low in HoN, and the game works fine!

Switching back to Nvidia card, and game starts lagging again, like stutter ones every second and also big delays/lag in teamfights.

How come I can't run the game with Nvidia RTX 2060 on my laptop? Latest drivers + windows update installed. Would be nice to play with Nvidia card and max graphics settings. 

  • Confused 1
Link to post
Share on other sites
  • 2 weeks later...

 

@oliiver

as im aware, hon isn't supported much anymore and has older hardware in mind. you just arent ever going to have high fps; 100-40 is what i average typically i have to restart my pc to get back to 100[1080 TI]. If your referring to ping, then what is ur ping? What servers are you playing on? type /gi and take a screen shot.  Find the form on these forums for laggy servers, i'm sure the developers would appreciatee if you posted that information.

Edited by Manu311
Link to post
Share on other sites
On 6/7/2020 at 6:42 PM, oliiver said:

The lag is not too bad when playing practice or against bots, but when playing midwars, its unplayable. 

If you have any lag at all while playing practice games, it's not related to servers or network. You can even play those games if you're disconnected from the internet.

The nvidia-problem on the other side is something I've read about more frequently. Apparently you have to tell nvidia-drivers (on Windows) that HoN is a game and needs the graphics card to be in performance mode instead of idle.

As a comparison, I'm on a very old and week notebook without dedicated graphics rn and I'm mostly over 50 fps on minimal settings. Certain skills cause a drop to around 20 FPS, but that's only for a few seconds.
Hardware: i5-2520M, 8 GB Ram, 7€ hdd

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...