Jump to content

****** Fatal Error: Couldn't load vid_gl2 ****** [LINUX-FEDORA]


Recommended Posts

I get the error in the title on my linux machine. 

 

 Intel Corporation UHD Graphics 620  with Intel Core  i5-8250U CPU H and fedora. Willing to provide any more information necessary, just have no idea what would be needed.

Link to post
Share on other sites
  • 2 weeks later...

Hey there,

lately I've been creating an AppImage for HoN on Linux, so you shouldn't get these kind of issues. So if you want the easy way out (which hopefully works), go download my AppImage from the following thread

 

About your issue, I've encountered this issue a couple of times, and it usually was related to issues with the files vid_gl2-x86_64.so in the hon-directory. That requires a bunch of libraries on your system. Sadly the information it prints out isn't always useful.
You could try the following command on that file and find any "not found" lines in it's output:

ldd vid_gl2-x86_64.so

 

Link to post
Share on other sites
  • 1 year later...

Been trying to run with the AppImage, and will check If it'll run but just in case it won't this is the output from the ldd:

Quote



bash-5.1$ ldd vid_gl2-x86_64.so
	linux-vdso.so.1 (0x00007fff02d7f000)
	libc++abi.so.1 => /storage/Games/HoN/./libs-x86_64/libc++abi.so.1 (0x00007f3fa7709000)
	libk2-x86_64.so => /storage/Games/HoN/./libk2-x86_64.so (0x00007f3fa6246000)
	libGL.so.1 => /usr/lib64/libGL.so.1 (0x00007f3fa6170000)
	libGLU.so.1 => /usr/lib64/libGLU.so.1 (0x00007f3fa60fe000)
	libX11.so.6 => /usr/lib64/libX11.so.6 (0x00007f3fa5fbe000)
	libc++.so.1 => /storage/Games/HoN/./libs-x86_64/libc++.so.1 (0x00007f3fa5cf6000)
	libm.so.6 => /lib64/libm.so.6 (0x00007f3fa5ba9000)
	libgcc_s.so.1 => /storage/Games/HoN/./libs-x86_64/libgcc_s.so.1 (0x00007f3fa5997000)
	libc.so.6 => /lib64/libc.so.6 (0x00007f3fa57b8000)
	libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f3fa5797000)
	libdl.so.2 => /lib64/libdl.so.2 (0x00007f3fa5792000)
	librt.so.1 => /lib64/librt.so.1 (0x00007f3fa5788000)
	libz.so.1 => /lib64/libz.so.1 (0x00007f3fa576c000)
	libxml2.so.2 => /usr/lib64/libxml2.so.2 (0x00007f3fa55fe000)
	libcurl.so.4 => /storage/Games/HoN/./libs-x86_64/libcurl.so.4 (0x00007f3fa5182000)
	libspeex.so.1 => /storage/Games/HoN/./libs-x86_64/libspeex.so.1 (0x00007f3fa4f63000)
	libspeexdsp.so.1 => /storage/Games/HoN/./libs-x86_64/libspeexdsp.so.1 (0x00007f3fa4d4d000)
	libpng12.so.0 => /storage/Games/HoN/./libs-x86_64/libpng12.so.0 (0x00007f3fa4b27000)
	libjpeg.so.62 => /storage/Games/HoN/./libs-x86_64/libjpeg.so.62 (0x00007f3fa48f8000)
	libfreetype.so.6 => /storage/Games/HoN/./libs-x86_64/libfreetype.so.6 (0x00007f3fa4661000)
	libawesomium-1-7.so.5 => /storage/Games/HoN/./libs-x86_64/libawesomium-1-7.so.5 (0x00007f3fa10a7000)
	libfmodex64.so => /storage/Games/HoN/./libs-x86_64/libfmodex64.so (0x00007f3fa0cf6000)
	libGLX.so.0 => /usr/lib64/libGLX.so.0 (0x00007f3fa0cc3000)
	libXext.so.6 => /usr/lib64/libXext.so.6 (0x00007f3fa0caf000)
	libGLdispatch.so.0 => /usr/lib64/libGLdispatch.so.0 (0x00007f3fa0bf4000)
	libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00007f3fa0a27000)
	libxcb.so.1 => /usr/lib64/libxcb.so.1 (0x00007f3fa09fe000)
	/lib64/ld-linux-x86-64.so.2 (0x00007f3fa843f000)
	liblzma.so.5 => /lib64/liblzma.so.5 (0x00007f3fa09d6000)
	libgobject-2.0.so.0 => /usr/lib64/libgobject-2.0.so.0 (0x00007f3fa097c000)
	libgthread-2.0.so.0 => /usr/lib64/libgthread-2.0.so.0 (0x00007f3fa0975000)
	libglib-2.0.so.0 => /usr/lib64/libglib-2.0.so.0 (0x00007f3fa0844000)
	libXi.so.6 => /usr/lib64/libXi.so.6 (0x00007f3fa0831000)
	libgtk-x11-2.0.so.0 => /usr/lib64/libgtk-x11-2.0.so.0 (0x00007f3fa03e0000)
	libgdk-x11-2.0.so.0 => /usr/lib64/libgdk-x11-2.0.so.0 (0x00007f3fa0325000)
	libpangocairo-1.0.so.0 => /usr/lib64/libpangocairo-1.0.so.0 (0x00007f3fa0314000)
	libgdk_pixbuf-2.0.so.0 => /usr/lib64/libgdk_pixbuf-2.0.so.0 (0x00007f3fa02e3000)
	libcairo.so.2 => /usr/lib64/libcairo.so.2 (0x00007f3fa01ac000)
	libpango-1.0.so.0 => /usr/lib64/libpango-1.0.so.0 (0x00007f3fa0159000)
	libfontconfig.so.1 => /usr/lib64/libfontconfig.so.1 (0x00007f3fa0110000)
	libXrender.so.1 => /usr/lib64/libXrender.so.1 (0x00007f3fa0103000)
	libnss3.so => /usr/lib64/libnss3.so (0x00007f3f9ffcf000)
	libnssutil3.so => /usr/lib64/libnssutil3.so (0x00007f3f9ff9a000)
	libsmime3.so => /usr/lib64/libsmime3.so (0x00007f3f9ff70000)
	libplc4.so => /usr/lib64/libplc4.so (0x00007f3f9ff69000)
	libnspr4.so => /usr/lib64/libnspr4.so (0x00007f3f9ff28000)
	libgconf-2.so.4 => /usr/lib64/libgconf-2.so.4 (0x00007f3f9ff00000)
	libdbus-1.so.3 => /usr/lib64/libdbus-1.so.3 (0x00007f3f9feac000)
	libXfixes.so.3 => /usr/lib64/libXfixes.so.3 (0x00007f3f9fea1000)
	libasound.so.2 => /usr/lib64/libasound.so.2 (0x00007f3f9fd9e000)
	libudev.so.0 => /storage/Games/HoN/./libs-x86_64/../libs-x86_64/libudev.so.0 (0x00007f3f9fd79000)
	libcups.so.2 => /usr/lib64/libcups.so.2 (0x00007f3f9fcdf000)
	libgcrypt.so.11 => /storage/Games/HoN/./libs-x86_64/../libs-x86_64/libgcrypt.so.11 (0x00007f3f9fa60000)
	libexpat.so.1 => /usr/lib64/libexpat.so.1 (0x00007f3f9fa2f000)
	libXau.so.6 => /usr/lib64/libXau.so.6 (0x00007f3f9fa28000)
	libXdmcp.so.6 => /usr/lib64/libXdmcp.so.6 (0x00007f3f9fa20000)
	libffi.so.7 => /usr/lib64/libffi.so.7 (0x00007f3f9fa14000)
	libpcre.so.1 => /lib64/libpcre.so.1 (0x00007f3f9f99c000)
	libXinerama.so.1 => /usr/lib64/libXinerama.so.1 (0x00007f3f9f997000)
	libXrandr.so.2 => /usr/lib64/libXrandr.so.2 (0x00007f3f9f988000)
	libXcursor.so.1 => /usr/lib64/libXcursor.so.1 (0x00007f3f9f97c000)
	libgmodule-2.0.so.0 => /usr/lib64/libgmodule-2.0.so.0 (0x00007f3f9f976000)
	libXcomposite.so.1 => /usr/lib64/libXcomposite.so.1 (0x00007f3f9f971000)
	libXdamage.so.1 => /usr/lib64/libXdamage.so.1 (0x00007f3f9f96c000)
	libatk-1.0.so.0 => /usr/lib64/libatk-1.0.so.0 (0x00007f3f9f942000)
	libgio-2.0.so.0 => /usr/lib64/libgio-2.0.so.0 (0x00007f3f9f773000)
	libpangoft2-1.0.so.0 => /usr/lib64/libpangoft2-1.0.so.0 (0x00007f3f9f75a000)
	libharfbuzz.so.0 => /usr/lib64/libharfbuzz.so.0 (0x00007f3f9f66e000)
	libpng16.so.16 => /usr/lib64/libpng16.so.16 (0x00007f3f9f638000)
	libpixman-1.so.0 => /usr/lib64/libpixman-1.so.0 (0x00007f3f9f590000)
	libEGL.so.1 => /usr/lib64/libEGL.so.1 (0x00007f3f9f579000)
	libxcb-shm.so.0 => /usr/lib64/libxcb-shm.so.0 (0x00007f3f9f574000)
	libxcb-render.so.0 => /usr/lib64/libxcb-render.so.0 (0x00007f3f9f564000)
	libfribidi.so.0 => /usr/lib64/libfribidi.so.0 (0x00007f3f9f546000)
	libplds4.so => /usr/lib64/libplds4.so (0x00007f3f9f541000)
	libdbus-glib-1.so.2 => /usr/lib64/libdbus-glib-1.so.2 (0x00007f3f9f515000)
	libelogind.so.0 => /lib64/libelogind.so.0 (0x00007f3f9f46b000)
	libgssapi_krb5.so.2 => /usr/lib64/libgssapi_krb5.so.2 (0x00007f3f9f419000)
	libkrb5.so.3 => /usr/lib64/libkrb5.so.3 (0x00007f3f9f342000)
	libk5crypto.so.3 => /usr/lib64/libk5crypto.so.3 (0x00007f3f9f314000)
	libcom_err.so.2 => /lib64/libcom_err.so.2 (0x00007f3f9f30e000)
	libgnutls.so.30 => /usr/lib64/libgnutls.so.30 (0x00007f3f9f145000)
	libcrypt.so.1 => /lib64/libcrypt.so.1 (0x00007f3f9f10b000)
	libgpg-error.so.0 => /lib64/libgpg-error.so.0 (0x00007f3f9f0e4000)
	libmount.so.1 => /lib64/libmount.so.1 (0x00007f3f9f087000)
	libresolv.so.2 => /lib64/libresolv.so.2 (0x00007f3f9f06c000)
	libgraphite2.so.3 => /usr/lib64/libgraphite2.so.3 (0x00007f3f9f041000)
	libcap.so.2 => /lib64/libcap.so.2 (0x00007f3f9f036000)
	libkrb5support.so.0 => /usr/lib64/libkrb5support.so.0 (0x00007f3f9f027000)
	libkeyutils.so.1 => /lib64/libkeyutils.so.1 (0x00007f3f9f020000)
	libp11-kit.so.0 => /usr/lib64/libp11-kit.so.0 (0x00007f3f9eeed000)
	libidn2.so.0 => /usr/lib64/libidn2.so.0 (0x00007f3f9eec9000)
	libunistring.so.2 => /usr/lib64/libunistring.so.2 (0x00007f3f9ed46000)
	libnettle.so.8 => /usr/lib64/libnettle.so.8 (0x00007f3f9ecfe000)
	libhogweed.so.6 => /usr/lib64/libhogweed.so.6 (0x00007f3f9ecb5000)
	libgmp.so.10 => /usr/lib64/libgmp.so.10 (0x00007f3f9ec3c000)
	libblkid.so.1 => /lib64/libblkid.so.1 (0x00007f3f9ebe9000)

I guess the only one missing is the first line: linux-vdso.so.1 (0x00007fff02d7f000) and the following message appears:

warning: The VAD has been replaced by a hack pending a complete rewrite

Maybe related to this: stackOverflowVDSO

/////****

Also currently testing if the honx86 version could run since the distro is installed with multilib, after installing the missing compat32 librariesGConf-compat32-3.2.6-x86_64-7compat32.txz & nghttp2-compat32-1.44.0-x86_64-1compat32.txz and directing the libudev to the 32-bit one the same error stills happen:

lariesadx@hp245g7 (32bit):/storage/Games/HoN$ ./hon-x86
warning: The VAD has been replaced by a hack pending a complete rewrite
****** Fatal Error: Couldn't load vid_gl2 ******

The ldd output is a bit different:

Quote

lariesadx@hp245g7 (32bit):/storage/Games/HoN$ ldd vid_gl2-x86.so
    linux-gate.so.1 (0xf7f86000)
    libc++abi.so.1 => /usr/lib/libc++abi.so.1 (0xf766b000)
    libk2-x86.so => /storage/Games/HoN/./libk2-x86.so (0xf63cb000)
    libGL.so.1 => /usr/lib/libGL.so.1 (0xf6358000)
    libGLU.so.1 => /usr/lib/libGLU.so.1 (0xf62df000)
    libX11.so.6 => /usr/lib/libX11.so.6 (0xf6197000)
    libc++.so.1 => /usr/lib/libc++.so.1 (0xf60c8000)
    libm.so.6 => /lib/libm.so.6 (0xf5f85000)
    libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0xf5f64000)
    libc.so.6 => /lib/libc.so.6 (0xf5d98000)
    libpthread.so.0 => /lib/libpthread.so.0 (0xf5d77000)
    libdl.so.2 => /lib/libdl.so.2 (0xf5d6f000)
    librt.so.1 => /lib/librt.so.1 (0xf5d64000)
    libz.so.1 => /lib/libz.so.1 (0xf5d49000)
    libxml2.so.2 => /usr/lib/libxml2.so.2 (0xf5bd6000)
    libcurl.so.4 => /usr/lib/libcurl.so.4 (0xf5b2f000)
    libspeex.so.1 => /usr/lib/libspeex.so.1 (0xf5b14000)
    libspeexdsp.so.1 => /usr/lib/libspeexdsp.so.1 (0xf5afe000)
    libpng12.so.0 => /storage/Games/HoN/./libs-x86/libpng12.so.0 (0xf5ada000)
    libjpeg.so.62 => /usr/lib/libjpeg.so.62 (0xf5a40000)
    libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xf597d000)
    libawesomium-1-7.so.5 => /storage/Games/HoN/./libs-x86/libawesomium-1-7.so.5 (0xf2854000)
    libfmodex.so => /storage/Games/HoN/./libs-x86/libfmodex.so (0xf269c000)
    libGLX.so.0 => /usr/lib/libGLX.so.0 (0xf2662000)
    libXext.so.6 => /usr/lib/libXext.so.6 (0xf264d000)
    libGLdispatch.so.0 => /usr/lib/libGLdispatch.so.0 (0xf25d0000)
    libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xf23f9000)
    libxcb.so.1 => /usr/lib/libxcb.so.1 (0xf23cd000)
    libatomic.so.1 => /usr/lib/libatomic.so.1 (0xf23c3000)
    /lib/ld-linux.so.2 (0xf7f88000)
    liblzma.so.5 => /lib/liblzma.so.5 (0xf2397000)
    libcares.so.2 => /usr/lib/libcares.so.2 (0xf237e000)
    libnghttp2.so.14 => /usr/lib/libnghttp2.so.14 (0xf2350000)
    libidn2.so.0 => /usr/lib/libidn2.so.0 (0xf232b000)
    libssh2.so.1 => /usr/lib/libssh2.so.1 (0xf22e7000)
    libpsl.so.5 => /usr/lib/libpsl.so.5 (0xf22d5000)
    libssl.so.1.1 => /lib/libssl.so.1.1 (0xf2237000)
    libcrypto.so.1.1 => /lib/libcrypto.so.1.1 (0xf1f66000)
    libgssapi_krb5.so.2 => /lib/libgssapi_krb5.so.2 (0xf1f14000)
    libkrb5.so.3 => /lib/libkrb5.so.3 (0xf1e47000)
    libk5crypto.so.3 => /lib/libk5crypto.so.3 (0xf1e17000)
    libcom_err.so.2 => /lib/libcom_err.so.2 (0xf1e12000)
    libldap-2.4.so.2 => /usr/lib/libldap-2.4.so.2 (0xf1dc3000)
    liblber-2.4.so.2 => /usr/lib/liblber-2.4.so.2 (0xf1db3000)
    libzstd.so.1 => /lib/libzstd.so.1 (0xf1ccb000)
    libbrotlidec.so.1 => /usr/lib/libbrotlidec.so.1 (0xf1cbd000)
    libbz2.so.1 => /lib/libbz2.so.1 (0xf1ca9000)
    libpng16.so.16 => /usr/lib/libpng16.so.16 (0xf1c6e000)
    libharfbuzz.so.0 => /usr/lib/libharfbuzz.so.0 (0xf1b6b000)
    libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0xf1b12000)
    libgthread-2.0.so.0 => /usr/lib/libgthread-2.0.so.0 (0xf1b0d000)
    libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0xf19d0000)
    libXi.so.6 => /usr/lib/libXi.so.6 (0xf19bd000)
    libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0xf152f000)
    libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0 (0xf1475000)
    libpangocairo-1.0.so.0 => /usr/lib/libpangocairo-1.0.so.0 (0xf1465000)
    libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0 (0xf1434000)
    libcairo.so.2 => /usr/lib/libcairo.so.2 (0xf12e8000)
    libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0xf1295000)
    libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0xf124b000)
    libXrender.so.1 => /usr/lib/libXrender.so.1 (0xf123d000)
    libnss3.so => /usr/lib/libnss3.so (0xf10d9000)
    libnssutil3.so => /usr/lib/libnssutil3.so (0xf10ab000)
    libsmime3.so => /usr/lib/libsmime3.so (0xf107d000)
    libplc4.so => /usr/lib/libplc4.so (0xf1076000)
    libnspr4.so => /usr/lib/libnspr4.so (0xf102d000)
    libgconf-2.so.4 => /usr/lib/libgconf-2.so.4 (0xf1005000)
    libdbus-1.so.3 => /usr/lib/libdbus-1.so.3 (0xf0fad000)
    libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0xf0fa6000)
    libasound.so.2 => /usr/lib/libasound.so.2 (0xf0e95000)
    libudev.so.0 => /storage/Games/HoN/./libs-x86/../libs-x86/libudev.so.0 (0xf0e6a000)
    libcups.so.2 => /usr/lib/libcups.so.2 (0xf0dea000)
    libgcrypt.so.11 => /storage/Games/HoN/./libs-x86/../libs-x86/libgcrypt.so.11 (0xf0d64000)
    libexpat.so.1 => /usr/lib/libexpat.so.1 (0xf0d36000)
    libXau.so.6 => /usr/lib/libXau.so.6 (0xf0d30000)
    libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xf0d27000)
    libunistring.so.2 => /usr/lib/libunistring.so.2 (0xf0ba4000)
    libkrb5support.so.0 => /lib/libkrb5support.so.0 (0xf0b94000)
    libkeyutils.so.1 => /lib/libkeyutils.so.1 (0xf0b8d000)
    libresolv.so.2 => /lib/libresolv.so.2 (0xf0b72000)
    libnsl.so.2 => /lib/libnsl.so.2 (0xf0b57000)
    libsasl2.so.3 => /usr/lib/libsasl2.so.3 (0xf0b37000)
    libbrotlicommon.so.1 => /usr/lib/libbrotlicommon.so.1 (0xf0b14000)
    libgraphite2.so.3 => /usr/lib/libgraphite2.so.3 (0xf0aeb000)
    libffi.so.7 => /usr/lib/libffi.so.7 (0xf0ae0000)
    libpcre.so.1 => /lib/libpcre.so.1 (0xf0a64000)
    libXinerama.so.1 => /usr/lib/libXinerama.so.1 (0xf0a5f000)
    libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0xf0a51000)
    libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0xf0a45000)
    libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0 (0xf0a3f000)
    libXcomposite.so.1 => /usr/lib/libXcomposite.so.1 (0xf0a3a000)
    libXdamage.so.1 => /usr/lib/libXdamage.so.1 (0xf0a35000)
    libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0xf0a0d000)
    libgio-2.0.so.0 => /usr/lib/libgio-2.0.so.0 (0xf082b000)
    libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0xf0812000)
    libpixman-1.so.0 => /usr/lib/libpixman-1.so.0 (0xf0784000)
    libEGL.so.1 => /usr/lib/libEGL.so.1 (0xf076d000)
    libxcb-shm.so.0 => /usr/lib/libxcb-shm.so.0 (0xf0768000)
    libxcb-render.so.0 => /usr/lib/libxcb-render.so.0 (0xf0758000)
    libfribidi.so.0 => /usr/lib/libfribidi.so.0 (0xf073b000)
    libplds4.so => /usr/lib/libplds4.so (0xf0736000)
    libdbus-glib-1.so.2 => /usr/lib/libdbus-glib-1.so.2 (0xf070d000)
    libelogind.so.0 => /lib/libelogind.so.0 (0xf0655000)
    libgnutls.so.30 => /usr/lib/libgnutls.so.30 (0xf048a000)
    libcrypt.so.1 => /lib/libcrypt.so.1 (0xf0456000)
    libgpg-error.so.0 => /lib/libgpg-error.so.0 (0xf042c000)
    libtirpc.so.3 => /lib/libtirpc.so.3 (0xf03fc000)
    libmount.so.1 => /lib/libmount.so.1 (0xf039c000)
    libcap.so.2 => /lib/libcap.so.2 (0xf0391000)
    libp11-kit.so.0 => /usr/lib/libp11-kit.so.0 (0xf0257000)
    libnettle.so.8 => /usr/lib/libnettle.so.8 (0xf0208000)
    libhogweed.so.6 => /usr/lib/libhogweed.so.6 (0xf01c0000)
    libgmp.so.10 => /usr/lib/libgmp.so.10 (0xf0148000)
    libblkid.so.1 => /lib/libblkid.so.1 (0xf00f1000)

    linux-gate.so.1 (0xf7f86000) here instead of linux-vdso.so.1 (0x00007fff02d7f000) but not sure what's the real issue here.🤔

InfoAboutLinuxGate , I understand it was a way to use some space address in order to play the game, could be deprecated now on this beta version of the distro, maybe using an older one will work I still have a real 32-bit box with slackware 14.2 to test.

Edited by lariesadx
Link to post
Share on other sites

I'll double post since I found the issue and the fix on my distro, hope it works on the one you use.

I was checking $HOME/.Heroes of Newerth/game/console.log and found the following error:

Error: [15:46:21] CSystem::LoadLibrary() - /storage/Games/HoN/libs-x86_64/../libs-x86_64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /usr/lib64/libGLU.so.1)

The fix is removing (made a backup of the original) the one on $HONPATH (the folder where you have the game installed): $HONPATH/libs-x86_64/libstdc++.so.6 and then symbolic link the one on your system:

on the libs-x86_64 directory
 

bash-$ ln -s /usr/lib64/libstdc++.so.6 libstdc++.so.6

The client ran and even updated.

Also tested on my 32-bit environment on my multilib distro the hon-x86 client binary and also worked , the only funny thing is the screen is darker that in the 64-bit binary but i guess just increasing the brightness will work, just don't run the hon.sh or it'll override the libudev.so since it gets the arch from the (uname -r) command.

Edited by lariesadx
  • Like 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...