Jump to content

Welcome to the Heroes of Newerth forums

The forums have received a complete makeover. Click the button below to read more about it.
Read more

Recommended Posts

Having some weird issues;

1. Can't login. If i continue to retry, i can eventually get in though.

2. Can't connect to chat servers / MM. Again, if i continue to log in and out (annoying due to issue #1), then it will sometimes connect.

3. Really jumpy / laggy game. If i can get past issue #1 and #2, then the game is really jumpy / laggy, even though my ping shows as fine.

4. Alt avatars missing entirely. On hero select and/or hero info, i cannot see any alt avatars.

I've done speed tests, and played other games while this is happening, and all is fine in terms of internet.

The interesting part is that if I connect to my VPN, the issues seems to go away.

Could my ISP be blocking something here?

Link to post
Share on other sites

The reason for vpn fixing this is probably the route your packets take. You're arbitrarily forcing the packets to go to your vpn-host first, so the route your packets take can be totally different.

If you want to fix #2 without having to go through #1 over and over, you can open Console (Ctrl+F8) and type "ChatConnect" into it.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...