Jump to content

Cursor bug when tabbing in/out of the game


Recommended Posts

The cursor is suppose to be locked when ingame (to the corners of the game), so to navigate the map. Sometimes when tabbing back into the game, the game does not lock the cursor into the game and when trying to navigate the camera, the cursor surpasses the edge of the game and continues out on the other monitor.

 

Similarly sometimes when tabbing out of the game, sometimes the cursor is still locked in the game.

That is

  • the cursor cannot move out of the monitor which the game runs on (trying to do so will only get it to the edge, and in doing so will actually move the camera inside the game)
  • The cursor presists the ingame cursor outside of the game. (Tried to screenshot it, but it wouldn't capture the cursor so had little to no value.)
  • The cursor cannot click on anything outside of the game.

 

To fix the issue, I have to tab in/out a couple of times until it resolves itself.

I run Ubuntu 20.04 with GNOME 3 as desktop environment.

 

systeminfo.txt

Client System Details:
OS: Linux 5.11.0-27-generic (x86_64)
Processor: Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz
Priority: 0
Afinity Mask: 255
Video: Unknown (1002:6939)
RAM: 2.54 GB/15.58 GB
Virtual Memory: 32767.94 GB/32768.00 GB
Page File: 2.00 GB/2.00 GB

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...