Jump to content

Cannot start HoN's native GNU/Linux client.

Recommended Posts

So I've been trying to run HoN on my GNU/Linux desktop but it wont start. I have been trying to search it up myself but I have not found any success. Just starting it from after installation, I get this error: 

./hon-x86_64: symbol lookup error: /lib/x86_64-linux-gnu/libcairo.so.2: undefined symbol: FT_Get_Var_Design_Coordinates

The solution that I've found to this was to delete the libfreetype.so.6 file from the directory. Instead I get this error:

warning: The VAD has been replaced by a hack pending a complete rewrite
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  1 (X_CreateWindow)
  Value in failed request:  0x0
  Serial number of failed request:  83
  Current serial number in output stream:  97

I've tried with the startup.cfg solution but it made zero difference. I've tried with the HoN x64 client through WINE well it runs but it bottlenecks pretty hard so it would be good if it was possible to just be able to run through the native GNU/Linux client.


I am using Debian 10 Buster with the desktop environment Xfce. I tried using GNOME but made no difference.

Edited by Ladonien
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...