Jump to content

Welcome to the Heroes of Newerth forums

The forums have received a complete makeover. Click the button below to read more about it.
Read more

HoN (64-Bit) Client Download [OFFICIAL RELEASE]


Recommended Posts

Gotta admit, was very sceptical at first, thinking what would 64bit HoN client would change as the engine is outdated as f**k, and thinking its a gimmick at most. I guess I was proven wrong.. So far stable 120+ FPS throughout all the stages of the match (This is really pleasant for someone who has 240hz monitor like me), so far so good, looking forward for future improvements of stability and multi-core support, to push that performance furthermore, keep up the good work!

Link to post
Share on other sites
  • Replies 139
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Heroes of Newerth (64-Bit)   Frostburn Studios is proud to release the HoN 64-Bit Client This is an alternative client for those seeking Greater Performance, stability and FPS Gains uti

Yep

FAQ   Q) What is HoN (64-Bit)? A) HoN (64-Bit) is built with technology 15 years senior to the current version of the game, as well as vastly upgrading multiple extension libraries with

Hello,

I downloaded the 64 bit client but it's not working properly. When I launch the game the splash screen with the HoN  64 logo fills my entire screen as it's supposed to but when I get to the login screen, the game screen becomes "smaller" so that I can see parts of my desktop behind it, because the game no longer fills the entire screen. Do you understand what I mean? However it is not in windowed mode with the windows stuff on top, it's "like" fullscreen but it's just that the game doesn't cover the entire screen like the splash screen did.

Also, the  game does not respond to mouse input, only to keyboard input. I.e. I can type my name into the log in fields but I can't click on anything, nothing happens. However I can move the cursor around and it has the HoN graphic style. When I go to the config file in My Documents I see that the resolution is set to 1920x1080 (same as my native desktop resolution) and that it is set to be in fullscreen.

I did not have these problems with the 32-bit client, which I have used for over a year on this computer. I completely uninstalled the 32-bit client before installing HoN 64.

How do I fix this?

Edited by gavlarN
Link to post
Share on other sites

@gavlarN

 

Please use the 64-Bit bug forum or join the 64-Bit bug discord ( link in OP )

---

To fix your issue, go to My Documents/Heroes of Newerth x64/game/startup.cfg and open this with notepad or any text editor.

 

Find a cvar named d3d_exclusive and set it to true, this should hopefully fix your issue.

This is most likely happening because the settings you copied over, you were using a lower than native res + borderless windowed.

We applied a fix recently unlocking how many video modes can be detected and this is a side effect of it.

Link to post
Share on other sites
12 hours ago, whoyami said:

return the Linux 64-bit client, please. And upgrade it to Vulkan API. And upgrade services to TLS 1.3, please

The Linux client is just hidden in a sub-forum, it's still working fine:

Occasionally some Linux Distributions don't work out of the box, so you either need to fiddle around with a couple of libraries, or you can use the AppImage I developed, which should work (if not, report bugs in it's own thread and I'll look into it):

 

Link to post
Share on other sites
2 hours ago, HyperXewl said:

@gavlarN

 

Please use the 64-Bit bug forum or join the 64-Bit bug discord ( link in OP )

---

To fix your issue, go to My Documents/Heroes of Newerth x64/game/startup.cfg and open this with notepad or any text editor.

 

Find a cvar named d3d_exclusive and set it to true, this should hopefully fix your issue.

This is most likely happening because the settings you copied over, you were using a lower than native res + borderless windowed.

We applied a fix recently unlocking how many video modes can be detected and this is a side effect of it.

Thanks, that worked! Sorry, I did not notice the link, I will use the appropriate forum the next time.

To be clear, I completely uninstalled the old client and didn't copy over any settings when I installed the new one, if this is issue is something you feel is necessary to troubleshoot (It might be off-putting to new users if the client does not work out of the box).

Link to post
Share on other sites
4 hours ago, HyperXewl said:

@gavlarN

 

Please use the 64-Bit bug forum or join the 64-Bit bug discord ( link in OP )

---

To fix your issue, go to My Documents/Heroes of Newerth x64/game/startup.cfg and open this with notepad or any text editor.

 

Find a cvar named d3d_exclusive and set it to true, this should hopefully fix your issue.

This is most likely happening because the settings you copied over, you were using a lower than native res + borderless windowed.

We applied a fix recently unlocking how many video modes can be detected and this is a side effect of it.

It's most likely happening because HoN (still) have issues with 4k displays. I had the issue now on a completely fresh install with no settings copied over.

Link to post
Share on other sites
3 hours ago, Jelle said:

It's most likely happening because HoN (still) have issues with 4k displays. I had the issue now on a completely fresh install with no settings copied over.

I had this problem on a 1920x1080 screen (laptop) with 125% screen scaling. Perhaps it's time for a thread in the bug forum.

Link to post
Share on other sites
On 11/6/2020 at 1:41 PM, HyperXewl said:

SHA256 sum

What is this? I asummed it was a torrent link but I can't open it with a torrent client. Does this actually allow me to download HoN64 if I somehow manage to find a way to download v2 torrents?

Link to post
Share on other sites
23 minutes ago, Emukle said:

What is this?

A "sha256 sum" is basically a "number" which you can generate if you have the entire huge file downloaded. If you change even a tiny bit of that file, the generated number will differ.
That way - once you downloaded the file, you can confirm it's 100% perfectly downloaded and doesn't contain viruses or anything other that's wrong.

There's also a torrent-link which should let you download the client via p2p. But that is not really connected in any special way.

Edited by Manu311
Link to post
Share on other sites

Finally, 32x version was a little screwed up for my pc, always having issues since... 2012, 2013 I guess.

I'll test this literally RN. I hope it doesn't come with the bug that crashes the game when creeps spawns (2/10 times) or when Riptide "touches" midlane water for the first time. Had this error like since Riptide debut.

Cheeers!

spacer.png

Link to post
Share on other sites
12 hours ago, HyperXewl said:

@gavlarN

To fix your issue, go to My Documents/Heroes of Newerth x64/game/startup.cfg and open this with notepad or any text editor.

Find a cvar named d3d_exclusive and set it to true, this should hopefully fix your issue.

This is most likely happening because the settings you copied over, you were using a lower than native res + borderless windowed.

We applied a fix recently unlocking how many video modes can be detected and this is a side effect of it.

I've had the same issue as gavlarN, and was able to learn some things.
I've got dual screens, 4k at 150% scaling and 2560x1600 at 125% scaling.
I installed with 32 bit in place, 32 bit set to full screen; exclusive mode; DirectX 9; vsync on

1st run, I got a display much larger than screen size then it shrank to a squished form only 2/3rds high but wider than the 4k screen. A first I though I couldn't click with the mouse, only type. Then I realized I could click at the top of the screen, played a bit and realized the 'click' zone and displayed cursor were not aligned. The 'mouse' coords seemed to be correct while the display was squished.
I hadn't read your note to gavlarN yet...
I found that I had to set windows scaling to 100%, then the initial display problem didn't happen. I could set exclusive mode and full screen; save those settings; exit Hon; set Win10 back to 150% scaling then go back in and it seemed normal. (haven't played yet, thought I come here to post about the scaling for anyone else having similar trouble - 4k is too small for 100% scaling!)

So... I think it's trying to render at 4k x 150%, then that's too tall but does fit across both screens, it 'scaled to fit' and shrunk verticle *then* corrected for the scaling so there were two corrections? Maybe the double scale would have been hidden if I had only 1 screen?

I hope that's a useful clue to the source of the problem...

Link to post
Share on other sites

I finally got this installed and working. It also had all sorts of problems scaling to the right resolution. I have 2 4K monitors and at first it was stuck with half on one monitor and half on the other. Then it was stuck with a 4K image but the top half of my left screen. Even thought it was hard to click on anything (mouse pointer wasn't aligned with the menus) I was able to repeatedly select the right settings and get it to work. 

As for the 64bit client itself it does work and I was able to play a few matches without any incident. However I don't see any benefit to this over the old client. The FPS seems to be the same, reaction time etc. all seemingly identical.

This client might benefit those with potato computers and video cards I guess.  No obvious benefits that I can see at all so far though. 

Link to post
Share on other sites
30 minutes ago, haradon said:

im getting lower fps on 64x (~90 on all high settings) where i get ~130 fps all high setting on 32 bit client. My pc is 64bit btw, can someone help?

I get 20-25fps instead of stable 60 (32x)

Edited by killewind
Link to post
Share on other sites
5 hours ago, superkev said:

I finally got this installed and working. It also had all sorts of problems scaling to the right resolution. I have 2 4K monitors and at first it was stuck with half on one monitor and half on the other. Then it was stuck with a 4K image but the top half of my left screen. Even thought it was hard to click on anything (mouse pointer wasn't aligned with the menus) I was able to repeatedly select the right settings and get it to work. 

As for the 64bit client itself it does work and I was able to play a few matches without any incident. However I don't see any benefit to this over the old client. The FPS seems to be the same, reaction time etc. all seemingly identical.

This client might benefit those with potato computers and video cards I guess.  No obvious benefits that I can see at all so far though. 

If you check the bug FAQ and the posts above, the solution is simply to use exclusive mode, which is recommended for maximum performance anyways.

The reason 32 bit even worked before is actually because, and I know how this sounds, because of a bug, and this bug was preventing other resolutions from appearing in the list such as 4k.

You can also fix this by modifying DPI scaling settings per app by right clicking your hon shortcut and going to properties.

Basically anyone who is scaling windows is gonna have issues, alot of older windows apps have issues.

--

It's not benefiting potato computers exactly, this can benefit anyone and it just depends on your CPU, Hardware and where your bottlenecks lie, and you may be getting more FPS than you think, IE watch a replay in a team fight right in the center of it and then watch that same replay on 64.

Edited by HyperXewl
Link to post
Share on other sites
43 minutes ago, killewind said:

I get 20-25fps instead of stable 60 (32x)

Please read FAQ, this is most likely due to you running HoN on a laptop where integrated graphics card is set to default.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...