Jump to content

HyperXewl

Staff
  • Content Count

    148
  • Joined

  • Last visited

  • Days Won

    21

Everything posted by HyperXewl

  1. This issue is fixed in an upcoming hotfix! (4.9.0.1) I don't have an ETA on deployment, and this isn't to get hopes up but its probably going to be deployed today! On that note, we are currently working on a Modern 64-Bit version of MAC, that we will officially support and has support for Big sur, if you'd like to help accelerate the release, we have a donation link at the top, every single dollar helps tremendously!
  2. HyperXewl

    hon for mac

    This issue is fixed in an upcoming hotfix! (4.9.0.1) On that note, we are currently working on a Modern 64-Bit version of MAC, that we will officially support and has support for Big sur, if you'd like to help accelerate the release, we have a donation link at the top, every single dollar helps tremendously!
  3. We have a hotfix ready but no ETA on when we can deploy it ( it's out of our control ) As soon as possible!
  4. This is the first I'm hearing of this and it may be an issue with your configuration. The 64-Bit client is in no way "less optimized" and in terms of performance it is superior in every way unless there is a specific issue or bug, there could be a more specific reason why you're having those issues. Some extra info would be great
  5. Hmmmmmmmmmmmmmmm. Maybe I could release a beta this month, as long as its understood that the factor it would be in would not be convenient, as in Unsigned/Won't ever be update-able/etc. I am very very very curious to hear how it would work on M1 as well tbh. As for release date, I really can't promise anything, but what I can tell you is that it does get in game and you can play right now, that much is done, thing is to do a proper official release we want to fix some of the long running issues in the GL2 pipeline so we can also do a linux release that is on par with windows.
  6. The patch for the 64-Bit client will be out in 2 hours, sorry about this!
  7. Oh gosh it's M1. Well, we have a 64-Bit Mac Client coming soon, it's currently in development, this seems to be ridiculously high in demand lately so we'll bump up the priority. If you'd like to help speed things up, we have a donation goal just for this: Donations - HoN Forums (heroesofnewerth.com) However this makes a 64-Bit version, not an M1 built version, so I have no idea how well that's going to run. M1 at least emulates 64-Bit although I don't know how well so...
  8. This can be for numerous reasons, did you install DirectX9 Redis? Try also clearing your configuration in Documents/Heroes of Newerth x64/game/startup.cfg ( delete the file ) If that doesn't work, try restoring it from bin and instead open it up and find the value d3d_exclusive and flip whatever value it is to true or false in reverse
  9. You are missing VC++ Redis 2019, you most likely unticked it during installation. You can get it manually here, https://aka.ms/vs/16/release/vc_redist.x64.exe
  10. Is this only during like a custom game or only during the loading-race thing? Could use a couple more instructions @Hubaris If your report is correct, I'll gift you some silvers mate.
  11. Was this during 4.8.6.5 patch? There was an issue where chromium was running mid game and was locking up cpu, this was fixed in this version. Otherwise it might be the AOE Targeting bug, but this one happens generally just before team fights, not during. Let me know if you ever have this issue again, if you do, it's probably the AOE targeting bug yes.
  12. Well to be fair, OpenGL is not the recommended API to use right now, its deprecated and I think I'm going to make that official by renaming the api name in game so people stop using it. It's only still there as an absolute last resort for compatibility and is in no way superior. Although we are doing a rewrite at the moment from scratch!
  13. Interesting info, thanks for this. Tho have you tried in VMWare 13+? Why are you using such an outdated version? I can't imagine there's really any other players who use such a low workstation version, is it for compat?
  14. HyperXewl

    Hon x64

    @Peodeo You need VC++ Redis 2019, here's the download link. https://aka.ms/vs/16/release/vc_redist.x64.exe This should have being automatically installed during the installer unless you unticked it or it failed in the background for some reason, sounds like you have some really messed up configuration. Hopefully that solves the issue.
  15. Honestly I've put countless hours into trying to fix it, but it was just insanity to try in the first place when I have absolutely no leads what so ever, I genuinely can't fix something I can't see
  16. The thing is, none of the staff have the bug, so we have no way to debug it. =\ The only way we can solve this problem is to directly work with someone who has the issue, everytime we've offered that no one has taken it up or has been too busy, so its being an endless loop of it being not fixed, there's genuinely nothing we can do until that happens
  17. You're not crazy! This is fixed next patch ( not hotfix ) ------ Information for the more technically adept who are reading this: The reason this is happening is it turns out these icons were not using pw^2 sizes, they where 128x135. We now use a CPU texture builder that in almost all cases will output the exact same result 1-1 of a GPU accelerated texture build, except in cases of breaking common 3D rules which video cards have overcome over the years, so technically speaking, the real bug is on 32-Bit! Haha.
  18. Go to Documents/Heroes of Newerth x64/game/startup.cfg and find d3d_exclusive and set it to true ( or the reverse ) to see if that helps. I can look into this later. ( also make sure hon is closed when you do this )Insert image from URL
  19. Why are you using OpenGL? It's a fallback only when you absolutely have to ( EG DirectX flat out crashes ) was this the case for you? Either way it's working okay for me, can you give me some more details or at the very least maybe tell me why directx was having issues for you?
  20. No, but! We are working on a MacOSX 64-Bit version actually, it will be released in a couple of months, It's alot of work, especially making it work properly on Big Sur ( which had even MORE issues ) We do have a working version already ! And it's fantastic, but its not ready for release. If you'd like to help, we have a donation goal specifically for this, anything helps, thanks! https://forums.heroesofnewerth.com/index.php?/clients/donations/ EDIT: Woke up and someone donated to it, thanks! \o/
  21. I found your 3 crash uploads and its related to nvd3dumx.dll, which is part of your nvidia drivers. This is a very hard issue to debug and is per PC, I'll need to get in touch with you to debug this, we have recieved quit a few crash reports of the same type, but its not related to the update directly. I'd love to help, message me or join that discord!
×
×
  • Create New...