Jump to content

Xaviero

Basic members
  • Content Count

    9
  • Joined

  • Last visited

Community Reputation

0 Neutral
  1. Sorry was bussy with stuff. I will check your image later this day.
  2. Update: I had no success of solving this problem. I still getting errors for both 32 and 64 bit versions. Updating and Downgrading mesa drivers for Intel HD Graphics 500. - Using Intel outdated drivers didn't helped too. - Tweaking libraries libc++,libpng didn't helped too. - Using different versions of OpenGL didn't helped too. At this point i am giving up, i had no problems from start with Steam.
  3. Dependacies listed at libraries.txt at game folder: - libcurl version 7.19.5 - libpng version 1.4.0 - libxml2 version 2.7.2 - Speex version 1.2 rc1 - zlib version 1.2.3 - Awesomium version 1.7.5.0 - Libgcrypt version 11-1.5.0 (Awesomium dependency) Returning to initial problem of running 32-bit version and getting Fatal Error: PNG header and library versions do not match makes me think that pictures "signed" with different version of libpng or libpng12.so.0 thais included in /libs-x86 is not a version 1.4.0 one. Why do HoN need libpng ? For including s
  4. Yeah game folder included libraries would probably solve most-to-all problems. Meanwhile trying to run 32-bit version and faced libgtk-x11-2.0.so.0 error. That indeed missing for x11 package i have installed on my system.
  5. both works, actually is output of the glxinfo | grep "OpenGL version"
  6. It doesn't matter if it sudo'ed or not. Output same for both cases. Also i have OpenGL 4.6 Mesa 20.2.0-deve1 (git-c794334 2020-05-25 bionic-oibaf-ppa). The freshest build.
  7. It would be easier if I get list of required graphical libraries for client. This way I could solve most-to-all problems for all graphic cards on linux.
  8. What i get from this is basically my system can't draw Window for launcher/client. Going deep on this i found out that instaling/updating libGL should solve this. I have Intel Graphics HD 500 and it seams that OpenGL supported by messa drivers/libraries. Maybe executable just doesn't know where to get those libs from...my best guess so far.
  9. I am trying to run HoN on Lubuntu 18.04.4 LTS. Currently i faced an issue when tried to launch game from Lutris warning: The VAD has been replaced by a hack pending a complete rewrite ****** Fatal Error: PNG header and library versions do not match ****** Eventually i googled this solution, but it seams like it doesn't helped. Then i tried to execute it from shell: $ sudo ./hon-x86_64 warning: The VAD has been replaced by a hack pending a complete rewrite libGL error: failed to create drawable libGL error: failed to create drawable X Error of failed request: GLXBad
×
×
  • Create New...