Thread: HoN performance

Page 2 of 2 FirstFirst 12
Results 21 to 35 of 35
  1. #21
    Offline
    Account Icon
    Join Date
    Sep 2009
    Posts
    821
    Rep Power
    8
    Try the upcoming patch if you have problems with your performance.
    There are some fixes in it which might help.

  2. #22
    Offline
    Account Icon
    Join Date
    Jan 2014
    Posts
    1,098
    Rep Power
    5
    Quote Originally Posted by nerdrage`ftw View Post
    well i think you noticed just as I did that HoN 4.0 had some major graphic tweaks and improvements. So...it's hard to say then.
    For reference, HoN runs perfectly fine on my four-year old machine. i5-3570K, 24GB of DDR3 RAM, Geforce 660 Ti. Ran fine before 4.0, ran fine after 4.0.

    I don't play as much as I used to, but I played enough Mid Wars to notice they completely redid the art assets on the Mid Wars map, after 4.0. No performance issues.

  3. #23
    Offline
    Account Icon
    Chat Symbol
    Join Date
    Apr 2011
    Posts
    149
    Rep Power
    6
    My framerate became more stable by putting Anisotropic Filtering at 16x instead of Trilinear. May sound odd because you would expect to have higher requirements of your GPU. I still have drops to 30/40 sometimes. But overall my performance increased, it runs pretty ok now. I am still going to get a new graphics card, I just want to play HoN at very high with 60 fps. Just buying new graphics card for HoN ))

  4. #24
    Offline
    Account Icon
    Chat Symbol
    Join Date
    Jul 2011
    Posts
    31
    Rep Power
    0
    I can tell you now the performance dipped

  5. #25
    Offline
    Account Icon
    Chat Symbol
    Join Date
    Apr 2011
    Posts
    149
    Rep Power
    6
    Well here I am again guys. I just received and installed my GTX 1060 and it runs pretty good. I am still surprised that I get drops to 40/50 FPS in busy teamfights. I think HoN engine causes this, and not my PC. The game runs smooth now at max but still. With a GTX 1060 and I5 6600 I should have 60 FPS at all times right?

  6. #26
    Offline
    Account Icon
    Chat Symbol
    Join Date
    Apr 2011
    Posts
    149
    Rep Power
    6
    I just had my framerate drop to 31! 31, with an i5 6600 and a 1060 GTX. Frostburn? What is this?
    I don't think this is caused by my PC. Everything runs as it should be. And I'm not saying HoN runs like total crap. But still having choppy/laggy plays at some moments when it gets very crowded. I think something IS wrong with HoN engine.

    https://ibb.co/ktbXtv


    best free image hosting sites

  7. #27
    Offline
    Account Icon
    Chat Symbol
    Join Date
    Apr 2011
    Posts
    149
    Rep Power
    6
    My performance in 3Dmark is kind of what you would expect (average) when compared with similar systems. Can anyone tell me how or why HoN is so laggy nowadays? I think it started with HoN 4.0
    I cannot just be the only one having this? Because I don't see a lot of complaints.

  8. #28
    Offline
    Account Icon
    Chat Symbol
    Join Date
    Oct 2013
    Posts
    12
    Rep Power
    0
    I have been having serious lag spikes when casting some abilities, for example DM's W, Chronos R, Pyro's Q n W, Bubbles Q. But it is interesting that when I try to cast Bubbles Q the game keeps running smooth. Tried to solve the issue thought Support and they never found it.

    I think the issue is related to the cast indicator, but I dont have the enough information/knowledge to confirm that.

  9. #29
    Offline
    Account Icon
    Join Date
    Sep 2009
    Posts
    821
    Rep Power
    8
    I'm just curious - but since OpenGL finally got rid of the graphic glitches - does the framerate with OpenGL suffer as much? You can switch it under windows and shouldn't see any difference (I think).

  10. #30
    Offline
    Account Icon
    Chat Symbol
    Join Date
    Apr 2011
    Posts
    149
    Rep Power
    6
    Quote Originally Posted by Manu311 View Post
    I'm just curious - but since OpenGL finally got rid of the graphic glitches - does the framerate with OpenGL suffer as much? You can switch it under windows and shouldn't see any difference (I think).
    Maybe worth to try. I will check this out.

  11. #31
    Offline
    Account Icon
    Chat Symbol
    Join Date
    Apr 2011
    Posts
    149
    Rep Power
    6
    Quote Originally Posted by thechunche View Post
    I have been having serious lag spikes when casting some abilities, for example DM's W, Chronos R, Pyro's Q n W, Bubbles Q. But it is interesting that when I try to cast Bubbles Q the game keeps running smooth. Tried to solve the issue thought Support and they never found it.

    I think the issue is related to the cast indicator, but I dont have the enough information/knowledge to confirm that.
    Yeah the framerate falls with certain hero abilities, like Bombardier with his W (dropping bombs)...
    Also watching replays is VERY laggy to say the least, for me it is. I don't know how or why. And it is not because of the fact I am running 2 instances of HoN, because this happens sometimes.
    Last edited by nerdrage`ftw; 02-17-2017 at 05:03 PM.

  12. #32
    Offline
    Account Icon
    Chat Symbol
    Join Date
    Apr 2011
    Posts
    149
    Rep Power
    6
    The graphics look different with OpenGL. Not as good, but I think that it will give me a good performance. But DirectX9 definitely gives better quality of models and effects.

    Maybe HoN is a heavier game than I would have thought. I do think that the game looks great nowadays, so it makes sense to me in that respect.
    With everything at highest settings AF and AA at highest etc. you simply need more than a GTX760 to run this game well. Therefore my 1060GTX is good enough.
    Last edited by nerdrage`ftw; 02-17-2017 at 04:47 PM.

  13. #33
    Offline
    Account Icon
    Chat Symbol
    Join Date
    Nov 2016
    Posts
    106
    Rep Power
    1
    maybe patch 4.0 corrupted some settings, try clean reinstall, also delete the hon folder in documents

    your PC should easily run it without problems, but patch 4.0 has also improved graphics quite a bit so its more taxing on the system.

    what FPS are you getting when just sitting in base doing nothing? on DirectX
    Last edited by best_carry; 02-17-2017 at 05:08 PM.

  14. #34
    Offline
    Account Icon
    Chat Symbol
    Join Date
    Apr 2011
    Posts
    149
    Rep Power
    6
    Maybe I can give it a try. But I installed Windows + HoN just recently. But I installed a new GPU in my system so, maybe it's best to do a clean install again. But I don't expect to get really better performance with that.
    Quote Originally Posted by best_carry View Post
    maybe patch 4.0 corrupted some settings, try clean reinstall, also delete the hon folder in documents

    your PC should easily run it without problems, but patch 4.0 has also improved graphics quite a bit so its more taxing on the system.

    what FPS are you getting when just sitting in base doing nothing? on DirectX
    60/59
    (i have vertical sync on) to prevent "tearing". It also remains 59/60 when someone is farming woods. Or when two people are laning. But when a major teamfight commences, or when a tower push commences, then it starts to drop to 45/50. But I measured 31 too last time. Kind of low for a GTX1060 and i5 6600?


    I don't feel that my GTX 1060 gives me THAT much of an improvement than the performance I had with a GX 760...maybe my CPU is a bottleneck? But I find that hard to believe.
    Maybe, like I said, HoN is a heavier game than you would expect at first.
    Other than that, game looks great, and better than Dota2 and LoL if you ask my opinion.
    Last edited by nerdrage`ftw; 02-17-2017 at 05:13 PM.

  15. #35
    Offline
    Account Icon
    Chat Symbol
    Join Date
    Apr 2011
    Posts
    149
    Rep Power
    6
    No, honestly. I think the performance SUCKS. I cannot get arouns the fact that I buy a graphics card of 289 euros to complete my new system, and I get this performance in HoN. And more frustrating the fact that Frostburn never replies or acknowledges or even tries to help me with this. Yes, I know theres a support section, but it's a GENERAL problem if you ask me

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •