Thread: HoN performance

Page 1 of 2 12 LastLast
Results 1 to 20 of 35
  1. #1
    Offline
    Account Icon
    Chat Symbol
    Join Date
    Apr 2011
    Posts
    149
    Rep Power
    6

    HoN performance

    So now I would like to open a thread to see how HoN performs nowadays on YOUR systems.
    I've got a new PC since june 2016. I5 6600. Intel 951 m.2 SSD, 32 GB DDR4 memory. Only thing not new is my GPU that I migrated to the new PC, a GTX 760.
    But since a couple weeks (actually since HoN 4.0) I have a poor performance in HoN. Verything at high settings. My frame drops to as low as 29 in major teamfights. Without action its always 60/59 FPS (limited).
    Now would you be so kind to share with me? I am curious, and google doesnt give me my answers since 2012 HoN is total different story than today.

  2. #2
    Offline
    Account Icon
    Chat Symbol
    Join Date
    Mar 2010
    Posts
    76
    Rep Power
    7
    ok man i have the same problem as you and i tried to solve it for the last more then 6 months. I can tell you what i did, so maybe something from here it will help you, or others reading this regarding LAG in game.
    TRY TO CONTACT SUPPORT : Support@Heroesofnewerth.com and they can help you better sometimes or at least they try their best .

    First make sure :
    0. Check for maleware / viruses and ADD exception for HoN in windows defender and win firewall - if you are using windows.
    1. Check your internet connection - if its wireless - try with a wired one - if you are using a router - try a direct connnection
    2. Check your drivers - for all the components of your pc , make sure all of them are up to date (including GPU driver, CPU drivers, Network Card Drivers)
    3. Try a FRESH install of games - delete both hon folders - which is basically where we remove all the components of Heroes of Newerth from your hard-drive and start from the ground-up. Firstly, uninstall your HoN client.
    Then, delete the settings directory:
    LINUX: ~/.Heroes\ of\ Newerth/game/
    WINXP: C:\Documents and Settings\[user]\My Documents\Heroes of Newerth\game\
    WIN7: C:\Users\[user]\Documents\Heroes of Newerth\game\
    MAC: /Users/[user]/Library/Application Support/Heroes of Newerth/game/
    Then find the main installation directory for HoN (where you ran the installer to install the files) and delete that folder.
    Download a fresh installer from: http://www.heroesofnewerth.com/download

    4. Clean up from dust PC fans ( to eliminate the overheat )
    5. Sadly HoN its a old game and cant take advantages of new processors ( its working on a SINGLE THREAD)
    6. Try to open a practice game - spawn some creeps and heroes and check if the lag still there - if it is, its not your internet.
    7. Try to lower your graphics - try to go all of them low / disable then if you dont have lag , try to increase the setting.
    8. Try to play without sounds - sometimes sound can increase the delay.
    9. Test all pc components with dedicated programs - test your RAM , GPU . CPU , Network Adapter with special programs google for them - and while u are in game get some programs to monitor PC resources and find out witch one is used 100% or close to this value.
    10. After a game - close HoN and open console.log check for this message "Assembled snapshot for frame xxxx from 2 pieces" -or you can check for this message while you are in game - opening console "Ctrl+F8"
    If this is the message you got - we are on the same page - and sorry but its my nightmare for a long time allready .

    TRy to post a copy of console.log here - maybe someone can have a look there and help you out !

    All the best and thanks for reading ,
    Sitting_Duck
    "Assembled snapshot for frame xxxx from 2 pieces" . If anyone knows how i can solve this please help . . My pc : I5 4570 ,8GB RAM , Radeon HD7850 . I tryed fresh install , reinstall hon, reinstall windows, update drivers, wired connection, new SSD, new network card, new Internet provider, tried to set high priority to HoN.exe. While in game 1 processor is 100% , all 3 others are 20% . PM here or add me in game. Thank you very much.

  3. #3
    Offline
    Account Icon
    Chat Symbol
    Join Date
    Apr 2011
    Posts
    149
    Rep Power
    6
    no its none of those problems. I tried clean Windows installment. And my connection is fine.

  4. #4
    Offline
    Account Icon
    Chat Symbol
    Join Date
    Nov 2016
    Posts
    106
    Rep Power
    1
    Seems that its a frequent problem for many people after 4.0

  5. #5
    Offline
    Account Icon
    Join Date
    Jun 2010
    Posts
    2,072
    Rep Power
    12
    There's a major improvement for HoN's performance coming up in the next patch.
    It will help greatly Mac Users, but it will also improve performance on Windows client.
    (>' ')> ^(' - ')^ <(' '<)


  6. #6
    Offline
    Account Icon
    Chat Symbol
    Join Date
    Apr 2011
    Posts
    149
    Rep Power
    6
    Would be great.

  7. #7
    Offline
    Account Icon
    Chat Symbol
    Join Date
    Aug 2016
    Location
    Minsk, Belarus
    Posts
    31
    Rep Power
    0
    Great news. Maybe I will finally be able play on my Windows 10 tablet (lol)

  8. #8
    Offline
    Account Icon
    Chat Symbol
    Join Date
    Mar 2010
    Posts
    76
    Rep Power
    7
    Quote Originally Posted by Tartalacame View Post
    There's a major improvement for HoN's performance coming up in the next patch.
    It will help greatly Mac Users, but it will also improve performance on Windows client.
    How do you know this ?
    "Assembled snapshot for frame xxxx from 2 pieces" . If anyone knows how i can solve this please help . . My pc : I5 4570 ,8GB RAM , Radeon HD7850 . I tryed fresh install , reinstall hon, reinstall windows, update drivers, wired connection, new SSD, new network card, new Internet provider, tried to set high priority to HoN.exe. While in game 1 processor is 100% , all 3 others are 20% . PM here or add me in game. Thank you very much.

  9. #9
    Offline
    Account Icon
    Chat Symbol
    Join Date
    Mar 2010
    Posts
    76
    Rep Power
    7
    Quote Originally Posted by nerdrage`ftw View Post
    no its none of those problems. I tried clean Windows installment. And my connection is fine.
    Did you open console.log ?
    and use Ctrl+F8 while u are in game and have lag . What message (error) do you have there if any ?
    "Assembled snapshot for frame xxxx from 2 pieces" . If anyone knows how i can solve this please help . . My pc : I5 4570 ,8GB RAM , Radeon HD7850 . I tryed fresh install , reinstall hon, reinstall windows, update drivers, wired connection, new SSD, new network card, new Internet provider, tried to set high priority to HoN.exe. While in game 1 processor is 100% , all 3 others are 20% . PM here or add me in game. Thank you very much.

  10. #10
    Offline
    Account Icon
    Chat Symbol
    Join Date
    Dec 2012
    Posts
    1
    Rep Power
    0
    Quote Originally Posted by Sitting_Duck View Post
    How do you know this ?
    Also curious

  11. #11
    Offline
    Account Icon
    Join Date
    Sep 2009
    Posts
    821
    Rep Power
    8
    My specs are in my signature (Besides the 16GB Ram and No Swap at all, but HoN hardly reaches 4GB, so that doesn't really matter).
    I had to turn down Anti-Aliasing from 16x to 4x for 4.0 and I also reduced Texture Filtering from Anisotropic 16x to Trilinear. (Primarily so I can run multiple clients of hon simultaneously without any lags). But now I never drop below 58 FPS.
    Everything else is still on maximum and enabled (beside VSync, but it still Vsyncs to my 60Hz), and my resolution is 1920x1080 in fullscreen (but I got a second monitor running, sometimes with yt videos on it).
    Last edited by Manu311; 02-04-2017 at 03:55 AM.

  12. #12
    Offline
    Account Icon
    Chat Symbol
    Join Date
    Apr 2011
    Posts
    149
    Rep Power
    6
    Quote Originally Posted by Sitting_Duck View Post
    Did you open console.log ?
    and use Ctrl+F8 while u are in game and have lag . What message (error) do you have there if any ?
    I will get back to you on that.

  13. #13
    Offline
    Account Icon
    Chat Symbol
    Join Date
    Apr 2011
    Posts
    149
    Rep Power
    6
    Nonetheless. I think this is an issue caused by HoN. Maybe it is requiring more video/cpu performance. But I had a better performance on my "old" PC with 16 GB Ram and an Intel Core i7 2600. I do admit that HoN looks good. Just the performance is poor...
    I will still upgrade my graphics card within the next couple of weeks. I already tried downgrading my Nvidia WHQL drivers, like someone suggested. Didn't help me.
    I also looked into the "Awesomium.exe" process in taskmanager. Didn't help me...
    Still I appreciate all your imput. Its nice to see people respond, better than doing nothing and just watching.
    I would like to see some imput from Frostburn devs, not just the moderators. Because of course the devs have a lot of knowledge about the subject.
    Most of the time, when checking my ping ingame. Many of the people have like 100 MS or higher ping. And I'm usually the one with the lowest ping (around 58), which is still not LOW. I would consider a ping of 16 to be LOW. But what can I say..it is what it is, I can't demand something that isn't gonna happen. I dont know how this is nowadays in other titles (like dota or LoL)

  14. #14
    Offline
    Account Icon
    Chat Symbol
    Join Date
    Apr 2011
    Posts
    149
    Rep Power
    6
    Here you can see my connection results


    Here you can see my PC specs
    https://tweakers.net/gallery/157047/inventaris/

    I will share tomorrow the console results, and maybe a screen from my taskmanager. Now I am doing everything I can to discuss and/or resolve the issue. Would be nice to see some Frostburn imput! I still love you Frostburn. No matter What the ****.

  15. #15
    Offline
    Account Icon
    Join Date
    Jun 2010
    Posts
    2,072
    Rep Power
    12
    Quote Originally Posted by Sitting_Duck View Post
    How do you know this ?
    Quote Originally Posted by Ehoq View Post
    Also curious
    I just read the forum :

    Jan 21st
    Quote Originally Posted by HyperXewl View Post
    I have got word that there has being optimizations done that will be deployed sometime soon to address the issue, so hang tight friends.
    [...]
    It's being looked into, and infact a fix is probably coming, but god damn, it's mac yo~
    Jan 31st
    Quote Originally Posted by ElementUser View Post
    Wait until 4.0.3, some memory optimizations are made to particularly help Mac users with the crash problems.
    I remember I read another one too, but I don't find it right now.
    Last edited by Tartalacame; 02-04-2017 at 11:56 PM.

  16. #16
    Offline
    Account Icon
    Join Date
    Sep 2009
    Posts
    821
    Rep Power
    8
    Quote Originally Posted by nerdrage`ftw View Post
    I would consider a ping of 16 to be LOW. But what can I say..it is what it is, I can't demand something that isn't gonna happen. I dont know how this is nowadays in other titles (like dota or LoL)
    So I've got one of the fastest possible connections in germany (50/10Mbit) and I'm quite close to Frankfurt - and if I ping some servers my ping response varies between 17 and 19ms.
    That's the case for servers that are far away from their load limits.
    Since players of the same game of HoN are all over europe (in the best case), obviously most people will have way higher pings. But the HoN-Ingame-Ping is bugged anyways, at least in pauses you can see pings very close to 0ms. That's simply impossible - it doesn't matter if the server is relaxing at that moment, the ping is simply wrong there.
    An other thing that I remember from wc3-times and various mods (like banlist): They often used latency and named it "ping". Ping is the time a packet requires to be transferred, read, send, transferred and read again. Latency on the other hand should be close to the "transferred" time. So latency is less then half the time of ping.
    And if you can advertise something, companies prefer to use the lower number, even if it's wrongly named.

    Also if you wondered how big the ping is to cross the ocean, pinging amazon.com results in 116ms for me (sadly all the other amazon-sites have ping disabled, so I can't give you timing on amazon.co.uk etc).

  17. #17
    Offline
    Account Icon
    Chat Symbol
    Join Date
    Nov 2009
    Posts
    128
    Rep Power
    8
    Try Shader Quality on medium and disable shadow quality. Fixed most of my performance issues.

  18. #18
    Offline
    Account Icon
    Chat Symbol
    Join Date
    Apr 2011
    Posts
    149
    Rep Power
    6
    It seems that changing my texture filtering from Trilinear to Anisotropic 16x has some positive impact on my framerate. Now I don't know how that makes sence, but it seems to help a bit, and improve my graphics as well.
    I think I used to have it on 16x since I played HoN, but somehow it was changed during some update.

  19. #19
    Offline
    Account Icon
    Join Date
    Jan 2014
    Posts
    1,098
    Rep Power
    5
    Quote Originally Posted by nerdrage`ftw View Post
    Nonetheless. I think this is an issue caused by HoN. Maybe it is requiring more video/cpu performance. But I had a better performance on my "old" PC with 16 GB Ram and an Intel Core i7 2600. I do admit that HoN looks good. Just the performance is poor...
    I will still upgrade my graphics card within the next couple of weeks. I already tried downgrading my Nvidia WHQL drivers, like someone suggested. Didn't help me.
    I also looked into the "Awesomium.exe" process in taskmanager. Didn't help me...
    Still I appreciate all your imput. Its nice to see people respond, better than doing nothing and just watching.
    I would like to see some imput from Frostburn devs, not just the moderators. Because of course the devs have a lot of knowledge about the subject.
    Most of the time, when checking my ping ingame. Many of the people have like 100 MS or higher ping. And I'm usually the one with the lowest ping (around 58), which is still not LOW. I would consider a ping of 16 to be LOW. But what can I say..it is what it is, I can't demand something that isn't gonna happen. I dont know how this is nowadays in other titles (like dota or LoL)
    If HoN ran better on older hardware, HoN isn't necessarily the problem. It's more likely to be newer drivers for newer hardware not performing as well.

  20. #20
    Offline
    Account Icon
    Chat Symbol
    Join Date
    Apr 2011
    Posts
    149
    Rep Power
    6
    well i think you noticed just as I did that HoN 4.0 had some major graphic tweaks and improvements. So...it's hard to say then.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •