Thread: Cannot run the game

Results 1 to 3 of 3
  1. #1

    Question Cannot run the game

    I have the exact same problem as this guy: http://forums.heroesofnewerth.com/sh...-12-04-problem
    I'm running on kubuntu last version.
    I played hon during 1 year on the same machine, no components were add, just reinstalled kubuntu after major crash.

    khaotyl@khaotyl:~/HoN$ ./hon.sh
    warning: The VAD has been replaced by a hack pending a complete rewrite
    K2 - Fatal Error: ARB_vertex_buffer_object not available.
    khaotyl@khaotyl:~/HoN$ glxinfo | grep -i "opengl\|direct\|server\|client" && lspci | grep -i vga && uname -a
    direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
    server glx vendor string: SGI
    server glx version string: 1.4
    server glx extensions:
    client glx vendor string: NVIDIA Corporation
    client glx version string: 1.4
    client glx extensions:
    OpenGL vendor string: nouveau
    OpenGL renderer string: Gallium 0.4 on NV96
    OpenGL version string: 1.4 (2.1 Mesa 8.0.2)
    OpenGL extensions:
    01:00.0 VGA compatible controller: NVIDIA Corporation G96 [GeForce 9600M GT] (rev a1)
    Linux khaotyl 3.2.0-24-generic-pae #37-Ubuntu SMP Wed Apr 25 10:47:59 UTC 2012 i686 i686 i386 GNU/Linux
    khaotyl@khaotyl:~/HoN$
    Last post in the other thread asks the OP to do

    mkdir -p "/home/$(whoami)/.Heroes of Newerth/game"; echo -e "SetSave \"vid_bpp\" \"32\"\nSetSave \"vid_refreshRate\" \"60\"\nSetSave \"vid_resolution\" \"$(xrandr | grep \* | cut -d' ' -f4 | tr x ,)\"\nSetSave \"gl_modesetting\" \"randr,randr11\"" > "/home/$(whoami)/.Heroes of Newerth/game/startup.cfg"

    but i don't get any response..

    Thx in advance for your help

    Edit

    After rebooting everything went fine.
    The command proposed by the host seems effective even if no message is displayed.
    Thx a lot
    Last edited by goldensugus; 04-29-2012 at 05:44 PM.

  2. #2
    Offline
    Account Icon
    Chat Symbol
    Join Date
    Aug 2009
    Location
    Ireland
    Posts
    1,860
    You should use the drivers from nvidia, the open source ones are not the best experience when playing hon but good that its fixed.


  3. #3
    Online
    Account Icon
    Chat Symbol
    Join Date
    Jul 2009
    Location
    UK - Brum
    Posts
    9,022
    reboot fixing this probably resulted in the nvidia module being loaded.

    Also that bash 1liner is no longer needed. hon has been patched to correct the issue requiring it

    Forum Moderators are not S2 Games employees. My posts in no way represent the view of S2 Games or any of its staff.

    Please use the report post function to have me review a post that you believe is breaking the Forum Rules.
    Check the Sticky Threads for additional information on this sub-forum and the Announcement Threads for more information about Heroes of Newerth as a whole!

    -----------------------------


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •