Thread: D3D CreateDevice fail

Results 1 to 6 of 6
  1. #1

    D3D CreateDevice fail

    Hi.

    When I start HoN I get the message K2- Fatal Error "D3D_Create: CreateDevice() failed.

    I have windows 7 64bit, GT580 graphic card and directx 11.

    All my drivers are updated. I linked my console.log


    http://tools.heroesofnewerth.com/view.php?key=0703ac20d08d3810&action=view

    What to do?

  2. #2
    Offline
    Account Icon
    Chat Symbol
    Join Date
    Jul 2009
    Location
    Rosenheim
    Posts
    525
    Hi,
    here a quote from the wiki.

    D3D_CreateDevice() failed and CHost::Init() - D3D_SelectMaterial: problem with NULL shader: g_iCurrentVertexShader invalid, g_iCurrentPixelShader invalid errors mean that your system cannot run directx 9.0c.
    • Cause 1: Graphics drivers not installed
      Solution 1: Install your graphics drivers
      Cause 2: Video card does not meet the minimum system requirements
      Solution 2: Replace your graphics card with one that meets the system requirements


    Also your console.log shows me that you got the video driver Version: 7.14.10.304 installed. This isn't the latest i think. Please refer to a guide from the internet how to update your drivers properly.
    Tech Support
    Follow the Wiki & remember console.log
    WINXP: C:\Documents and Settings\[user]\My Documents\Heroes of Newerth\game\
    WIN7: C:\Users\[user]\Documents\Heroes of Newerth\game\
    MAC: /Users/[user]/Library/Application Support/Heroes of Newerth/game/
    LINUX: ~/.Heroes\ of\ Newerth/game/
    Need Live help? irc://irc.s2games.com/#techsupport

  3. #3
    Quote Originally Posted by KaZoOoKa View Post
    Hi,
    here a quote from the wiki.

    D3D_CreateDevice() failed and CHost::Init() - D3D_SelectMaterial: problem with NULL shader: g_iCurrentVertexShader invalid, g_iCurrentPixelShader invalid errors mean that your system cannot run directx 9.0c.
    • Cause 1: Graphics drivers not installed
      Solution 1: Install your graphics drivers
      Cause 2: Video card does not meet the minimum system requirements
      Solution 2: Replace your graphics card with one that meets the system requirements


    Also your console.log shows me that you got the video driver Version: 7.14.10.304 installed. This isn't the latest i think. Please refer to a guide from the internet how to update your drivers properly.
    Hello!
    Cause 3: A Secondary monitor is running in background (or from driver)
    Solution: Press Windows-Button + P, select "Only Computer".

    This worked for me, because i use my old TV to watch streams. It seems to collide with HoN and drop this Error. My Tv was not running, but i have to select it as "Only Computer" so just try. I have 2x 9800gt with sli.

  4. #4
    i have the same problem please help this is my computer's infohttp://pastebin.com/nLFELi3M and here is my console.log http://pastebin.com/JBSxy8Fy

    please help. thanks in advance

  5. #5

    K2- Fatal error. D3D_create: createdevice() failed

    Would remove everything from mine computer, clean it completely from any application. Did it installed all my driving routines again, updated all software and still I get answer K2- Fatal error. D3D_create: createdevice() failed

  6. #6

    Possible FIX for D3D_Create: Create De

    Quote Originally Posted by lillebuske View Post
    Hi.

    When I start HoN I get the message K2- Fatal Error "D3D_Create: CreateDevice() failed.

    I have windows 7 64bit, GT580 graphic card and directx 11.

    All my drivers are updated. I linked my console.log


    http://tools.heroesofnewerth.com/view.php?key=0703ac20d08d3810&action=view

    What to do?

    I had the same problems with my brand new laptop (lenovo G580)
    I went to the lenovo site to download all the drivers.
    Then I went to download and install hon, then this "D3D_Create: CreateDevice() failed came up every single time!
    I checked the Internets and figured it had do with the graphics somehow.

    I went to the search bar at the start button typed in device manager, clicked it, then in device manager i clicked display drivers.

    Now I saw my newly installed driver for the graphic card Nvidia Geforce 610M and then another: Standard VGA driver (or something similar) it only says "Standard VGA driver" if you have the wrong driver or a really old one installed so I right clicked it and pressed update driver then search for driver on the internet but windows was telling me the driver was up to date.

    If you right click it but then choose properties instead of update drivers then select the tab "Drivers" there you can see the Date and what version you have, mine was saying 2006, well fuk that I thought there is the problem!

    So at the beginning I had only installed the drivers for the graphic card but forgotten the drivers for the processor graphic witch in my case was Intel HD 4000.

    Now HoN works fine for me, hope I helped someone!
    Cheers!
    Last edited by Turglarokhn; 03-02-2013 at 06:16 PM. Reason: missclicked post

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •