Toggle Snow
 

Thread: Changed to OpenGL and HoN won't start up

Results 1 to 11 of 11
  1. #1
    Offline
    Account Icon
    Chat Symbol
    Join Date
    Nov 2009
    Location
    Melbourne, Australia
    Posts
    66

    Changed to OpenGL and HoN won't start up

    I changed my gfx settings to OpenGL, and clicked restart game. After that, the game failed to restart, and I can't open hon up. It also doesn't show up as running on task manager. Is there anyway to revert my gfx settings back to dx9 without actually opening HoN?

  2. #2
    Offline
    Account Icon
    Chat Symbol
    Join Date
    May 2010
    Location
    Toronto, Canada
    Posts
    1,285
    I'll look but for now try going into your HoN folder and finding a graphics setting text file that you can edit with notepad. There should be a line there that you can either change to directx or set as true or false.

  3. #3
    Offline
    Account Icon
    Chat Symbol
    Join Date
    Nov 2009
    Location
    Melbourne, Australia
    Posts
    66
    Found set save "host_viddriver" "vid_gl2"
    Not sure if this is the line for open gl option, and not sure what to input for dx9

  4. #4
    Offline
    Account Icon
    Chat Symbol
    Join Date
    Nov 2009
    Location
    Melbourne, Australia
    Posts
    66
    nvm fixed it, with "vid_d3d9" ty anyway

  5. #5
    Offline
    Account Icon
    Chat Symbol
    Join Date
    May 2010
    Location
    Toronto, Canada
    Posts
    1,285
    EDIT: NEVERMIND you got it.

    Ok, I think this might help. I'm not a computer expert but I'll give it a go:


    • Go to C:\Documents and Settings\HP_Administrator\My Documents\Heroes of Newerth\game
    • Open up startup with notepad or wordpad
    • Press CTRL+F and put "host_vidDriver"
    • Click Find Next, it should bring to the line
    • Change the second pair of quotes at the end of the line to "vid_d3d9"

    Let me know if it works.

  6. #6

    Another option

    If that doesn't work try this, it worked for me

    On the shortcut that you use to play HoN, do the following;

    right click -> properties

    then under target add this to the end -vid vid_d3d9

    so the line should look like the following

    "C:\Program Files (x86)\Heroes of Newerth\hon.exe" -vid vid_d3d9

  7. #7
    This was very helpful, thanks.
    지금은 소녀시대!, 앞으로도 소녀시대!, 영원히 소녀시대!

  8. #8
    Well if you got many crash reports they said i should change it to run in openGL but when i do i get the same problem as this guy it wont start. Anyway to fix so it dont crashes when i turn on openGL? Iam also trying bcdedit /set IncreaseUserVA 307 I will return once i tryed it out.2
    Last edited by Matsuchi; 11-30-2011 at 05:24 PM.

  9. #9
    Cant find my fcking startup.cfg file, help som1?

  10. #10
    Quote Originally Posted by HiJoe View Post
    Cant find my fcking startup.cfg file, help som1?
    Go to C:\Documents and Settings\Your_Username\My Documents\Heroes of Newerth

    Should be somwhere there.


  11. #11
    Offline
    Account Icon
    Chat Symbol
    Join Date
    Feb 2011
    Location
    New Zealand
    Posts
    2,486
    OpenGL makes my cursor into a black square GG

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •